Erro ao criar um projeto react - básico

Olá, estou com um problema ao tentar criar um projeto react, aparece a seguinte mensagem de erro: “You are running create-react-app 4.0.2, which is behind the latest release (5.0.1).”
Alguém sabe como resolver?


Usei o comando npx create-react-app gamagit
e apareceu a mensagem postada acima.

4 Likes

Adicione o print da tela de erro e informe o comando que você executou pra chegar nesse erro. Talvez ajude a alguém te ajudar.

Fala @Rayane, a solução está no print que você mandou.

  • Desinstale o CRA globalmente: npm uninstall -g create-react-app
    (para garantir tente remover do yarn tbm)
  • Desinstale o CRA globalmente: yarn global remove create-react-app
  • Feche o terminal.
  • Abra novamente o terminal, navegue até onde deseja criar seu projeto e execute:
    npx create-react-app gamagit
4 Likes

Obrigada pela sugestão @edubarros101 , ninguém vai adivinhar se eu não mostrar. :grin:

1 Like

Opa, funcionou! Muito obrigada @pedro-mascarenhas por sua ajuda.

1 Like

Por nada, @Rayane!

Fazer melhores perguntas também faz parte das skills que nós temos que desenvolver. E falo isso me incluindo, claro.

É tipo o protocolo no-hello.

Bons estudos! :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.