Erro na hora de instalar o express e o npm

Olá pessoal,

Estou vendo a playlist de testes e estava seguindo os passos do professor, mas durante as instalações do express e do npm que ele faz na primeira aula de jasmine, retornaram esses erros, queria saber se alguém mais teve algo parecido e se tem algum problema, porque aparentemente o express e o npm estão instalados apesar disso.

image

image

3 Likes

A última atualização do express-generator foi há 3 anos (ou 6 anos). Então é normal o NPM retornar esse erro dizendo que as dependencias que o express usa estão desatualizadas.

Por exemplo, algumas dependencias até mudaram de nome.

No caso Warn não são erros, são avisos. Como o colega de cima informou, eles estão te avisando que algumas coisas mudaram nome e estão desatualizadas.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.