* [lista de exercícios comunitária] * [algoritmo] *

parabéns pela iniciativa, vai me ajudar muito

Que top mano, e vamos à prática :smiley: :muscle:

programa {
funcao inicio() {
real C, resultado

	escreva ("Digite temperatura em Celsius: " )
	leia(C)
	resultado = (9*C+160)/5
	escreva ( "Conversão em Farenheit: ", resultado)

}

}

Acredito que assim esteja correto, certo?

programa {
funcao inicio() {
real a, resultado
escreva ("Informe o custo de fábrica do veículo: ")
leia (a)
resultado = (a*1.25)*1.45
escreva ("Custo total para o consumidor: ", resultado)
}
}

Esse eu sofri um pouco pra fazer kkkkk não tava conseguindo fazer a potência funcionar

programa {

inclua biblioteca Matematica --> mat

funcao inicio() {
    
    real a,b,c, resultado
	escreva ("Digite o valor depositado: ")
	leia (a)
	escreva ("Digite o rentabilidade da poupança: ")
	leia (b)
	escreva ("Digite o tempo de aplicação: ")
	leia (c)
	
	resultado = mat.potencia(1+b, c)*a
	
	escreva ("Valor final: ", resultado)
	
}

}

1 Like
function separarIdades (listaDeIdades){
   let maioresDeIdade = [];
   let menoresDeIdade = [];
   let maiorIdade = listaDeIdades[1];
   let menorIdade = listaDeIdades[1];
  
   for(let i = 0; i< listaDeIdades.length; i++){
      if(listaDeIdades[i] >=18){
        maioresDeIdade.push(listaDeIdades[i])
      }else{
        menoresDeIdade.push(listaDeIdades[i])
      }
    
      if(maiorIdade < listaDeIdades[i]){
         maiorIdade = listaDeIdades[i]
      }
      if(menorIdade > listaDeIdades[i]){
        menorIdade = listaDeIdades[i]
      }
  }
  
  return `Existem ${maioresDeIdade.length} pessoas maiores de idade e ${menoresDeIdade.length} pessoas menores de idade onde o mais velho tem ${maiorIdade} anos e o mais jovem possui ${menorIdade} anos`
}
console.log(separarIdades([4,55,16,22,45]))

A gente testa na prática. Se rodar, é só conferir se o código tá limpo kkk

Não sabia que a vírgula funcionava como substituto para o “+”
Eu fiz dessa forma:

programa {
funcao inicio() {
real c, f
escreva("Digite a temperatura em °C: ")
leia(c)
f = (9*c+160)/5
escreva(c+"°C = "+ f +“°F”)
}
}

Opa, blz?
Eu não pedi para o usuário informar o tempo de aplicação pois no enunciado pede o valor de rendimento após um mês kkk
Fiz de forma bem simples:

programa {
funcao inicio() {
real valor, rendimento, valorFinal
escreva(“Digite o valor depositado: R$”)
leia(valor)
rendimento = (valor*0.07)
valorFinal = valor + rendimento
escreva(“Em um mês, o valor de R$”+valor+" renderá “+rendimento+”\n Logo, o valor final será de R$"+valorFinal)
}
}

Opa, blz?

Porque 1,25 e 1,45?
Não seria 0,28 (28%) e 0,45 (45%)?
Outra informação importante no enunciado é que devemos aplicar primeiro os impostos e depois a porcentagem do distribuidor.

Eu fiz dessa forma:

programa {
funcao inicio(){
real custo, imposto, percentual, preco
escreva(“Digite o custo de fábrica do veículo: R$”)
leia(custo)
imposto = (custo * 0.45)
custo = (custo + imposto)
percentual = (custo * 0.28)
preco = (custo + percentual)
escreva(“Aplicando impostos e percentual do distribuidor, o preço deste veículo será de R$”+preco)
}
}

Boa noite!
Tudo bem?

O pessoal já pulou logo pra javascript! kkk
Ainda não cheguei nessa parte em JS, fiz todos em Portugol mesmo, mas eu notei que no seu código você já inseriu os números. O enunciado pede para que o usuário entre com 10 números, de forma aleatória.

Então o correto, neste caso é criar uma variável “contador” e inserir dentro de uma estrutura de repetição, que também deve conter uma condicional para separar os pares dos ímpares digitados pelo usuário, armazenando-as em suas respectivas variáveis.

Vou mostrar como fiz em Portugol:

programa {
funcao inicio() {
inteiro numero, contador, par, impar
par = 0
impar = 0
para (contador = 1 ; contador <= 10; contador = contador +1) {
escreva("Digite o "+contador+"º número: ")
leia(numero)
se (numero % 2 == 0) {
par = par + 1
} senao {
impar = impar + 1
}
}
escreva(“Foram digitados “+par+” números pares e “+impar+” números ímpares”)
}
}

Ainda não cheguei nessa parte de JS pessoal kkkk
Eu fiz tudo em Portugol. Logo, vou mostrar como fiz desta forma:

programa {
funcao inicio() {
inteiro idade, maiores, menores, maior, menor, contador
maiores = 0
menores = 0
maior = 0
menor = 0
idade = 0
contador = 1

	enquanto (contador <= 5) {
		escreva("Digite a " + contador + "ª idade: ")
		leia(idade)

		se (idade >= 18) {
			maiores = maiores + 1
			} senao {
				menores = menores + 1
				}

		se (contador == 1) {
			menor = idade
			maior = idade
		}

		se (idade > maior) {
			maior = idade	
			}			
		se (idade < menor) {
			menor = idade
			}
			
		contador = contador + 1
		}
		
	   escreva("Das idades digitadas, "+menores+" são menores de idade e "+maiores+" são maiores de idade \nMaior idade digitada: "+maior+"\nMenor idade digitada: "+menor)
	}
}

programa {
funcao inicio() {
cadeia nome, senioridade
real valorHora, horas, salario, aumento, total

Escreva (“Digite seu nome”)
leia (nome)

Escreva (“Digite sua senioridade”)
leia (senioridade)

Escreva ("Digite o valor da sua hora de trabalho ")
leia (valorHora)

Escreva ("Digite o total de horas trabalhadas no mês ")
leia (horas)

salario = valorHora * horas

se (senioiridade = “pleno”)
{
aumento = ( salario0,15 )
total = ( salario
1,15 )
}
senao
{
se (senioridade = “sênior”)
{
aumento - ( salario0,20 )
total = ( salario
1,20 )
}
}
senao
{
total = salario
}

Escreva (nome; senioridade; salario; aumento; total)

}

}

Interessante o raciocínio que você usou @paulohenrique3140 para não haver problema quanto à digitação da senioridade, pq pode ser que a pessoa escreva de um jeito diferente do que coloquei no código, daí daria erro né…

1 Like

rograma {
funcao inicio() {
real c, f
escreva ("Digite a temperatura em °C: ")
leia (c)

	f = (9*c+160)/5
	
	escreva (c+"°C equivale a " +f+ "°F")
}

}

1 Like