Endpoint List all SKU IDs Does Not Respect Query Params

Hello guys,

First, a little bit of context.

I am currently working on an integration with the VTEX API, my main objective is importing all the product images from VTEX to our database. We would manage to do that with the “Catalog API” by getting all the SKUs using the “List all SKU IDs” endpoint and after that we would get the images from each SKU with the endpoint “Get SKU and context”, we tested this approach before, and it looked a nice way to do this.

By now we are on the final steps of development and most of the integration code is already done, so, when testing our solution, we noticed that the endpoint “List all SKU IDs” has some type of error, because it does not recognize the query parameters, I am sending to it.

To exemplify the error, I will continue with an example.

The “List all SKU IDs” endpoint requires two query params, page and pagesize, both are mandatory. But, when I try to use the endpoint does not matter if I send any query params, the list of SKUs that returns are always the same.

I tried to send different values on the query parameters, and it does not change the result. I tried to send no value at all as query params and the result still the same as well, both are odd behaviors, but the second one is especially odd because I thought that the API would send me some type of error if I did not send the required parameters.

My conclusion is that the endpoint does not recognize the query params I send, it simply does not matter if I send something or not, I always receive the same 200 response, with the same list of SKUs.

I think that this odd behavior could be some type of bug from the API. I am willing to share all the information of my requests if it is necessary, maybe it is a bug with my user, but I cannot share my user credentials in a public forum, so if there some private types of getting in contact with the VTEX staff, let me know.

To conclude this topic, the ideal scenario is to find the bug with this endpoint, so we would not need to change the core of the implementation.

Hello there.

I use it everyday and it´s working without any problems. Are you using this?

1 Like

@John.Jahn ,

I could ask you to put here how you are doing the resquest, but VTEX is being very quick to respond to tickets, so you can send them your question and they will respond you very quickly. I had same issues in the past with other endpoints and they help me to clarify the problem. By dealing directly with them via email you can copy sensitive data if necessary

1 Like

Thank you for the answers, I understand the limitation of help I can get without sharing the requests, but the Saito reply already helped me, it confirms that there is no problem with the API, so it must be a problem with my user, unfortunately I just have one pair of credentials to do my requests, but I will try to follow the Luiz suggestion and go talk to VTEX directly, probably it is the best thing to do.


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.