Error: node@4.x builder failed to install dependencies through yarn

HI guys

I trying publish an app custom, but the console show this error:

I read others post in this comunity, relationship about this theme, but I dont resolve the issue.

Thanks Comunity

I have this same problem
Did you manage to solve it?

Hi Yasmin, I couldn’t resolve it

We had a similiar problem here and I found out that was related to the VTEX/test-tools, so I changed to an older version and it worked.

@vtex/test-tools”: “^2.1.1”

Hope this helps.

Juan, the problem happened when your package run on old node version, but there is a solution for that.

You will put in package.json the property called “resolutions”, ex:

“resolutions”: {
“expect”: “25.5.0”

But Nicholas, why do you put the 25.5.0?

After you put the code on package.json, you need to run “yarn” to indexed on yarn.lock. Then the terminal will shows a log similar to this:

warning package.json: No license field
warning No license field
[1/4] 🔍 Resolving packages...
warning Resolution field "expect@25.5.0" is incompatible with requested version "expect@^29.0.0"

The expect@25.5.0 is the solution, then you put on the resolutions.

“resolutions”: {
“expect”: “25.5.0”

After this, you run the command VTEX setup and VTEX link

The instruction is:

Terminal shows the error log? Add resolutions on package.json with “package”: “25.5.0”

Run yarn, the same will shows the log with exact version to associate on package.json.

After this, you run the VTEX setup and VTEX link

Same solution over here. Deleted everything related to test tools and it worked.

1 Like