Loja dá erro ao acessar o site sem o www no HTTPS não entra

Semana passada colocamos no ar o nosso novo site, mas estamos com problema no apontamento https://cfg.com.br que está sem funcionar.

Observo que o site está funcionando para
http:// cfg. com .br
http:// www. cfg. com .br
https:// www. cfg. com .br

mas hora nenhuma consigamos fazer voltar a funcionar o:
https://cfg.com.br

que sempre usamos no site antigo (e que tinha já muitos anúncios apontados para ele no Google Ads)

Li em outros posts que só preciso instalar um certificado no servidor e apontar o CNAME “.” para meu servidor e lá fazer um arquivo de exemplo um .htaccess para redirecionar para a VTEX.

Seria isto mesmo ? Como e onde devo inserir essa informação .htaccess

Olá Mike, tudo bem?

Pelo que percebi vendo a configuração, é que estão usando o serviço da “Direcionar” conforme explicado na página de suporte da VTEX.
https://help.vtex.com/pt/tutorial/configurando-acceso-sin-www--tutorials_4278#

O que acontece é que a “Direcionar” não possui suporte para HTTPS e neste caso existem algumas opções:

  1. Vocês instalarem um servidor próprio com Apache (ou similar), criarem um certificado SSL, instalarem o certificado no seu servidor e configurarem o redirecionamento. O servidor pode ficar na AWS, Azure, Google, enfim, onde acharem melhor.
  2. Procurarem um serviço similar ao da “Direcionar” que ofereça suporte para HTTPS. Talvez alguma outra pessoa lembre de algum porque nunca cheguei a precisar.
  3. Verificar com o seu provedor de DNS atual se eles oferecem algum serviço de redirecionamento HTTP → HTTPS.