Primeiro VTEX Admin App - vtex link (cmd)

Olá !!!

Estou desenvolvendo meu primeiro Admin APP (seguindo o “HelloWorld” do material Aplicações administrativas)

Toda a parte de frontend funciona normalmente, mas após inclusão do modulo node (para conectar com serviços e api’s), no momento da compilação do app (com vtex link), o erro abaixo é apresentado.
“node@4.x builder failed to install dependencies through yarn”
"graphql@16.0.1: the engine node is incompatible with this module. expected version “^12.22.0 || ^14.16.0 || >= 16.0.0”. got “12.16.1”

Inclusive o próprio HelloWorld do treinamento esbarra no mesmo erro somente no último passo.

Não sei se pode ser algo do meu ambiente.
Versão do vtex cli: vtex/3.8.1-beta.e606849e win32-x64 node-v12.12.0
SO: windows

Muito obrigado por qualquer ajuda !!!

Olá, @fabio.versolatto

“node@4.x builder failed to install dependencies through yarn”
"graphql@16.0.1: the engine node is incompatible with this module. expected version “^12.22.0 || ^14.16.0 || >= 16.0.0”. got “12.16.1”

Você deve atualizar sua versão do node, pelo menos 12.22.0 (recomendo >14)
Após atualizar… Você pode remover a pasta node_modules e buildar novamente. Creio que vá resolver seu problema.

Olá @ecarlosvao !!! muito obrigado pelo seu retorno !!!

Também havia pensado nisso !!! Mas a minha versão do node é a v17.2.0
Não funcionou também

Fala @fabio.versolatto!

Geralmente, as majors ímpares do Node não são estáveis. Tenta utilizar a v16, pode ser que ajude.

Olá @AlysonBasilio !! obrigado pelo seu retorno!

v16.13.1 do node … mesma coisa. :confused:

Fala Fabio, conseguiu resolver o problema?

Se não, o problema pode estar em uma dependência do graphql adicionada sem uma versão bem definida.
No arquivo yarn.lock do projeto vc encontra isso?

graphql "*"

Se sim, substitui o * por 14 para fixar a versão do graphql (Atualmente ele importa a versão 16 do graphql que é incompatível com a versão do node utilizada no VTEX IO, por isso aparece essa mensagem de erro para vc). Depois é só remover a pasta node_modules e tenta rodar um vtex link. Espero que agora funcione. :pray:

Olá @AlysonBasilio !!! obrigado pela resposta e pela atenção !!!

Fiz o que você sugeriu, o mesmo erro de novo …

Será que a minha versão do VTEX CLI está com algum problema de compatibilidade?

Consegue subir o código dessa app em um repositório e compartilhar cmg? Eu posso testar aqui na minha máquina e ver se consigo reproduzir o erro…

1 Like

Com certeza !!!

Qual é o seu endereço de email?(que eu adiciono sua permissão ao link que eu vou te passar)

Muito obrigado mesmo pela ajuda !!! @AlysonBasilio

2 Likes

@fabio.versolatto eu tentei rodar o código que vc me mandou na minha máquina, mas aconteceram alguns erros diferentes do que você mandou aqui e eu vi que você fez algumas alterações além do que tá proposto lá no passo a passo do tutorial, daí não consegui fazer rodar.

Mas, eu percebi que no arquivo node/yarn.lock tem o seguinte trecho de código:

"@types/graphql@^14.0.7":
  version "14.5.0"
  resolved "https://registry.yarnpkg.com/@types/graphql/-/graphql-14.5.0.tgz#a545fb3bc8013a3547cf2f07f5e13a33642b75d6"
  integrity sha512-MOkzsEp1Jk5bXuAsHsUi6BVv0zCO+7/2PTiZMXWDSsMXvNU6w/PLMQT2vHn8hy2i0JqojPz1Sz6rsFjHtsU0lA==
  dependencies:
    graphql "*"

Se você substituir o graphql "*" por graphql "14", remover a pasta node/node_modules e rodar um yarn install dentro da pasta node deveria fazer funcionar.
O mesmo no arquivo react/yarn.lock, remover a pasta react/node_modules e rodar um yarn install dentro da pasta react deveria fazer funcionar. Vc pode testar isso daí no seu lado? Talvez antes de implementar as coisas novas que você adicionou no código.

Olá Alyson ! não tenho nem como agradecer a atenção !!! Obrigado mesmo !

Então, os yarn install nas pastas react e node rolam legal… (com alteração para 14… coloquei o meu fonte atualizado no link abaixo)…

O problema está justamente no vtex link… que continua dando o mesmo erro … :confused:
Fiquei pensando, será que não é a versão do meu vtex cli?
[vtex/3.8.1-beta.e606849e win32-x64 node-v12.12.0]

parece que ele não respeita a versão do node builder do projeto…

Olá Fabio, você conseguiu resolver seu problema, estou com o mesmo erro que você. Por favor, você pode me dizer o que você fez para resolvê-lo.

Muito obrigado.