Store.home is not render

I created an account and clone store-theme repo, then I run these commands on terminal:

  • VTEX login [my-new-account]
  • VTEX use [a-new-workspace]
  • VTEX link
  • VTEX browse

My store is in production, and CMS/Pages have a home template(a single option showing: but only header and footer is rendering.

Hey @Zaninde, can you run VTEX ls and show to us the return of it?

Also, did you change the vendor on the manifest.json file?

1 Like

Hello Nikolavno, how are you?

Yes, my vendor on manifest.json is my name account.

I created a repo on github with source if you want see: GitHub - mercatoPiselli/minimun-boilerplate-vtex

When a run VTEX ls, the return is:

The problem is that the is installed. is the same thing as a primary store, so your changes do not reflect in your workspace because the VTEX theme and your theme are conflicting.
Try these steps below:

1 - Run vtex uninstall;
2 - Run the vtex link again and see if any changes that you do on the template will propagate to the VTEX environment

If you need anything more, just shout me out here!


I followed these two steps and had an different behavior, where a blank space appeared (home div), now look like that i have no home in my store.

here is when i ran vtex ls:
Edition Apps in mercatopiselli at workspace mercatoworkspace
VTEX.admin 4.42.0
VTEX.admin-apps 3.29.2
VTEX.admin-audit 2.3.0
VTEX.admin-binding 0.28.0
VTEX.admin-cms 1.10.0
VTEX.admin-collections 0.162.3
VTEX.admin-docs 0.4.3
VTEX.admin-graphql-ide 3.6.2
VTEX.admin-home 3.7.2
VTEX.admin-insights 4.4.2
VTEX.admin-inventory 0.49.3
VTEX.admin-login 1.24.2
VTEX.admin-logistics 1.36.1
VTEX.admin-mercadolivre-opportunities 0.7.9
VTEX.admin-orders 0.134.2
VTEX.admin-pages 4.49.8
VTEX.admin-pickup-points 2.13.2
VTEX.admin-pricing-settings 1.6.1
VTEX.admin-sales-performance 1.1.3
VTEX.admin-search 1.65.8
VTEX.admin-sellers 1.3.7
VTEX.admin-sku-binding 0.5.0
VTEX.admin-sponsor 1.0.2
VTEX.admin-suggestions 2.35.1
VTEX.admin-users 1.16.1
VTEX.admin-vendor-invite 0.12.0 0.1.1
VTEX.asset-server 0.15.5
VTEX.audit-io 0.1.4
VTEX.auth-admin 3.60.1
VTEX.auth-server 0.18.0
VTEX.billing 0.24.0
VTEX.broadcaster 0.9.0
VTEX.builder-hub 0.285.4
VTEX.cartman 0.3.1
VTEX.checkout 0.6.0
VTEX.client-admin-settings 0.7.0
VTEX.cms-builder-sf-jamstack 1.8.0
VTEX.colossus-legacy-proxy 2.3.5
VTEX.developer-docs-integration 0.5.6
VTEX.dotnet-messenger-sender 0.1.7
VTEX.evolution-manager-graphql 0.15.3
VTEX.file-manager 0.11.0
VTEX.intelligent-search-api 0.6.3
VTEX.invoice-notifier 0.8.2
VTEX.marketplace-network 0.17.1
VTEX.messages 1.66.1
VTEX.messages-templates 0.10.1
VTEX.messenger-core 0.1.9
VTEX.mkp-category-mapper-ui 1.20.2 1.25.0 1.5.0
VTEX.myuser-io 2.18.1
VTEX.notification-generator 0.6.2
VTEX.omnishipping 1.19.6
VTEX.order-auth 1.6.2
VTEX.orders-broadcast 0.3.0
VTEX.pix-payment 0.12.2
VTEX.promotions-simulator 0.2.3
VTEX.request-capture 2.2.2
VTEX.reverse-registry 0.6.14
VTEX.rewriter 1.56.5
VTEX.sales-performance-graphql 0.7.13 1.63.0
VTEX.seller-provisioner 0.2.1
VTEX.seller-welcome 0.2.0
VTEX.shipping-preview 0.11.1
VTEX.sms-messenger-sender 0.1.0
VTEX.smtp-messenger-sender 0.1.0
VTEX.sno 0.0.3
VTEX.sse-server 0.3.3 2.127.1 2.14.0 1.2.0
VTEX.toolbelt-telemetry 0.1.3
VTEX.transform-handlebars-email 0.1.12
VTEX.transform-handlebars-sms 0.1.4
VTEX.transform-render-email 0.1.7
VTEX.transform-render-sms 0.1.7

Installed Apps in mercatopiselli at workspace mercatoworkspace
VTEX.admin-promotions 1.5.0
VTEX.admin-v4-docs 0.1.0
VTEX.admin-webpage-performance 0.1.0
VTEX.facebook-fbe 1.7.2 1.0.3 3.3.1
VTEX.mega-menu 2.8.1 3.11.2
vtexbr.tiktok-tbp 1.2.2
vtexromania.advanced-seller-onboarding 0.6.5

Linked Apps in mercatopiselli at workspace mercatoworkspace 0.0.0

and here is my home.json:

Can you please send me your manifest.json?

Also, I will send you a dm with my contact, reach me so we can call about it!

1 Like

I already had a problem similar to this, basically you need to have a file called blocks.json and not blocks.jsonc in the root of the store folder.

Remember that it must be in the root of the store folder and not store/something else

I believe that if you link the theme directly to the page module within the editor site it will work