Upgrading from admin@0.x to admin@1.x

Hi there,

I’ve got a problem on the upgrading from admin@0.x to admin@1.x, how can I upgrade to admin@1.x, when I’m receiving the error: can’t use vtex.builder@0.284, I tried vtex install vtex.builder@0.x, tried to run vtex autoupdate but no luck

Please advice me on this :pray:

Thank you in advance!

Hey Sirev. This admin@0x is very old indeed. Do you have some contact here at VTEX so we can have a look at this? Or even give me your account? Thanks.

1 Like

I’ve got as contact now as tech reviewer mateuspontes and ericbarcellos as business reviewer, these names are listed in github review thread, but I can share you account: productleadpartnerro

thanks, awaitin response :handshake:

Sirev, when looking at the productleadpartnerro account i see that you’re all good with the current admin@3.x version.
Could you give me a bit more context? We’re talking about an IO based app right? For the VTEX admin? Is that a dependency?

Yes, we’re building a VTEX app IO which has react app on Admin, node with 2 clients: masterdata and third party both through ExternalClient integration (extends). At the run compilation admin@1.x builder is failing saying that hub-builder.0.284 is outdated

Just confirmed what i was thinking, we only got one version of the admin builder and it is the 0.x.
Where did you get this information about a 1.x version?

It was a reply from homologation process: :roll_eyes:

but as I understood the guy that reviewed is not working at Vtex anymore

Indeed. Can you just give me the repo or the app’s name to double check?



If there’s no major versions then we can close this thread. thank you very much! :pray:

I’m checking with the team behind the review process to update this. But yes, i think we’re good. keep it open until i got a follow up from them.

1 Like

It’s being taken care of Sirev. This topic can be closed.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.