Erro de build no vtex link

Pessoal, estou recebendo esse erro de node, diz que precisa da versão maior ou igual a 12.22 e que minha versão é a 12.16. Porém, no meu computador a versão do node é a 14.16.1.

react@3.x builder failed to install dependencies through yarn (retries=0)
yarn errors:
react-hook-form@7.25.1: The engine "node" is incompatible with this module. Expected version ">=12.22.0". Got "12.16.1"
Found incompatible module.

Boa tarde, eu ACHO, que pode ser a versão que a vtex está usando no workspace, não conheço nenhum comando que dá pra ver essa informação, você pode tentar também utilizar outra versão do react-hook-form para ver se funciona!

2 Likes

Olá, Kallebe!

A versão do Node que utilizamos no IO é a 12.16.1, por isso esse erro ocorreu apesar da versão do Node na sua máquina estar mais atualizada. O react-hook-form@7.25.1 requer que a versão do Node seja pelo menos 12.22.0, então procurei uma versão do react-hook-form que fosse compatível com nossa versão e encontrei a 7.21.2.

O erro parou de acontecer quando passei a usar essa outra versão:

Assim como o @huandersonmachado, recomendo usar outra versão do react-hook-form.
Espero que essa resposta te ajude!

1 Like