Graphql@16.3.0: The engine "node" is incompatible with this module

Por favor estoy siguiendo los pasos del curso aqui:

pero cuando lanzo el comando vtex link me sale este error:
graphql@16.3.0: The engine “node” is incompatible with this module. Expected version “^12.22.0 || ^14.16.0 || >=16.0.0”. Got “12.16.1”

Ya actualice node a la ultima version a dia de hoy a la version 16.14.2 asi que no es un tema de actualizar node.

Por favor decirme que me puede faltar, mi package.json se ve asi:

Hola @rocamil85

Teniendo en cuenta tu problema, hemos modificamos la versión del “@vtex/test-tools” ubicado “devDependencies” en el package.json de la carpeta node. Esta versión paso de ser “^1.0.0” a “^3.4.3”. Finalmente, es necesario eliminar el archivo yarn.lock y seguido ejecutar nuevamente el proyecto usando vtex link.

Adjunto la evidencia de mi package.json

image

El ajuste es necesario ya que entran en conflicto las versiones de las dependencias.

Si tu problema persiste, no dudes en escribir nuevamente.

Saludos,

2 Likes

Hola Erika muchas gracias, lo que hiciste me solucione el problema,saludos.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.