Graphql@16.5.0: The engine "node" is incompatible with this module

Hi everyone I don’t know if this is the right section where I can speak about my problem.
I’ve got a custom app and when I launch vtex link I get the following error:

error: react@3.x builder failed to install dependencies through yarn (retries=3)
yarn errors:
graphql@16.5.0: The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.16.0 || ^16.0.0 || >=17.0.0". Got "12.16.1"
Found incompatible module. vtex.builder-hub@0.285.1

I already read this Graphql@16.3.0: The engine "node" is incompatible with this module - #2 by erika.beltran and I tried updating @vtex/test-tools to “^3.4.3” but I keep having the same error.

The json inside react folder:

  "name": "reviews",
  "scripts": {
    "test": "vtex-test-tools test"
  "dependencies": {
    "prop-types": "15.6.2"
  "devDependencies": {
    "@types/classnames": "^2.2.7",
    "@types/graphql": "^14.5.0",
    "@types/jest": "^24.0.11",
    "@types/node": "^11.13.0",
    "@types/prop-types": "^15.7.0",
    "@types/ramda": "^0.26.5",
    "@types/react": "^16.8.10",
    "@types/react-intl": "^2.3.17",
    "@vtex/test-tools": "^3.4.3",
    "@vtex/tsconfig": "^0.4.4",
    "apollo-client": "2.4.12",
    "graphql": "^15.3.0",
    "react": "16.3.2",
    "react-apollo": "3",
    "react-intl": "3",
    "typescript": "3.9.7",
    "vtex.pixel-interfaces": "",
    "vtex.product-context": "",
    "vtex.product-review-interfaces": "",
    "vtex.product-summary-context": "",
    "vtex.render-runtime": "",
    "vtex.slider-layout": "",
    "": "",
    "": "",
    "vtex.styleguide": ""
  "version": "2.2.1"

Hey @Davide90! After changing the @vtex/test-tools version, did you remove the yarn.lock file and run yarn again? If not, that’s probably the issue.

The yarn.lock file locks the installed dependencies to a specific version and ensure that every install results in the exact same file structure in node_modules across all machines.

By removing it, you force yarn to resolve dependencies again.

I’m having the same issue, I follow the @georgebrindeiro instructions but the error has not changed

Same issue here.